Site performance issues

Incident Report for PhoneBurner

Resolved

Site performance has been restored. We've determined that an upstream provider was having performance issues that degraded some aspects of our site. We have mitigated those issue and the site is performing well. We'll continue monitoring.
Posted Jul 09, 2025 - 08:39 PDT

Monitoring

We are seeing full site performance recovery. We are monitoring.
Posted Jul 09, 2025 - 08:08 PDT

Identified

We've identified the source of the issue and we're remediating. We're starting to see performance improvements.
Posted Jul 09, 2025 - 07:47 PDT

Investigating

We are investigating issues with the site
Posted Jul 09, 2025 - 07:36 PDT
This incident affected: Website, Dialer, API, and SMS.